Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #3697

    ‘Fatal error: Web Invoice requires PHP 5.2 or better. Please upgrade or switch to a host that supports PHP 5.2 like Pacific Host. in /var/www/vhosts/ on line 1063’

    Basically means I can’t upgrade any more, I’m stuck with 2.0.10


    ah, if everything works fine in 2.0.10 could I know the PHP version you are using?


    Btw, after WordPress 3.1.x series you will not be able to upgrade WordPress as well if you don’t run at least PHP 5.2.0, you should seriously consider asking your web host to upgrade their PHP version.



    I think you are running PHP 5.1.6 on CentOS. See how to upgrade to PHP 5.2.6 .


    yes it’s 5.1.6

    oh, it’s For WordPress 3.2, due in the first half of 2011, we will be raising the minimum required PHP version to 5.2.

    So you’re about one year too soon


    Do you think you could upgrade to PHP 5.2.6 ? It’s very simple and since you are on a VPS there is nothing preventing you. If you insist that you cannot upgrade to 5.2.6 I’ll try to make Web Invoice compatible with PHP 5.1.6.

    Since PHP 5.2.0 was released around 4 years ago (02 Nov 2006), I was assuming it was safe to set the minimum requirement there and also I had to use a function that’s introduced in PHP 5.2 .

    Is anyone else having issues upgrading to PHP 5.2.6?


    I’ll ask the host support first as it’s not something I know anything about.


    Ok I upgraded to 5.2


    Cool :)

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.